L'interface de la fenêtre d'image et ses composants

L'interface de la fenêtre d'image et ses composants



Capture de la fenêtre d'image illustrant ses principaux composants.



GIMP démarre avec une fenêtre d'image vide appelée « Éditeur d'image GIMP ». Dès que vous ouvrez une image, elle apparaît dans cette fenêtre et ses spécifications sont affichées dans la barre de titre selon les réglages que vous avez effectués dans Préférences. Vous pouvez ouvrir d'autres images qui s'afficheront chacune dans une fenêtre particulière. Nous commencerons par une brève description des éléments par défaut dans une fenêtre ordinaire. Certains peuvent être supprimés en utilisant les commandes du menu Affichage si vous le désirez.

1. Barre de titre :



En haut de la fenêtre image se trouve probablement la barre de titre dans laquelle s'affiche le nom de l'image et quelques informations de base. La barre de titre est en fait générée par le gestionnaire de fenêtre du système et non par GIMP, aussi son apparence peut changer selon le système d'exploitation, le gestionnaire de fenêtre et/ou le thème. Dans le Dialogue des préférences vous pouvez personnaliser les informations qui y apparaissent.

2. Barre des Menus :



Juste en dessous de la barre de titre se trouve le « Menu d'image » (à moins qu'il n'ait été désactivé). Ce menu vous permet d'accéder à presque toutes les opérations réalisables sur une image. Vous pouvez aussi dérouler le menu image en cliquant avec le bouton droit sur l'image [1] , ou bien en cliquant sur la flèche dans le coin supérieur gauche, si l'une de ces méthodes vous convient mieux. De plus, la plupart des opérations du menu peuvent aussi être activées depuis le clavier, en utilisant Alt et une touche « accélératrice » soulignée dans le texte du menu. Enfin, vous pouvez définir vos propres raccourcis clavier pour les actions du menu, si vous avez autorisé Utiliser les raccourcis clavier dynamiques dans le dialogue des Préférences.


3. Bouton Menu :



Cliquer sur ce petit bouton déroule le Menu d'image sur une colonne au lieu d'une ligne. Ceux qui utilisent les accélérateurs claviers et qui n'ont pas la barre des menus visible peuvent accéder au menu d'image par la touche Maj+F10.

4. Les règles :



Dans la configuration par défaut, les règles sont affichées en haut et à gauche de l'image, elles indiquent les coordonnées dans l'image. Vous pouvez choisir le type de coordonnées affiché. Par défaut, l'unité de mesure est le pixel, mais vous pouvez choisir une autre unité en utilisant les paramètres d'unité décrits plus loin.

Un des usages majeur des règles est de créer des guides. Si vous cliquez sur une règle et que vous la glissez dans l'image affichée, un guide va être créé que vous pouvez dès lors utiliser pour vous positionner précisément dans l'image. Les guides sont déplaçables en cliquant dessus ; ramenez-les vers leur règle d'origine pour les ôter de l'image.

5. (Dés)activer le masque rapide :



En bas à gauche de la fenêtre image se trouve un petit bouton qui permet d'activer ou de désactiver le masque rapide qui est une manière alternative, et souvent très utile, de voir la partie sélectionnée d'une image. Pour plus d'information voyez la section Masque rapide.

6. Coordonnées du pointeur :



Dans le coin inférieur gauche de la fenêtre image s'affiche les coordonnées du pointeur (c.-à-d. la position de la souris, si vous utilisez une souris), tant que le pointeur se trouve sur l'image. L'unité est la même que pour les règles.

7. Menu des unités :



Par défaut, l'unité utilisée pour les règles et d'autres fonctions est le pixel. Vous pouvez la changer pour le centimètre, le pouce ou bien d'autres possibilités en utilisant ce menu. Si vous le faites, sachez que le paramètre « Point pour point » du menu Affichage modifiera les dimensions d'affichage de l'écran : Voyez Point pour point pour plus d'informations.

8. Bouton Zoom :



Il y a plusieurs manières de zoomer plus ou moins dans l'image, mais ce menu est rapide d'accès et affiche la valeur courante du zoom. Avec GIMP-2.6, il est maintenant possible d'entrer le niveau de zoom voulu directement dans la boîte de texte.

9. Barre d'état :



elle se situe en bas de la fenêtre d'image. Par défaut, elle affiche la partie active de l'image, et la quantité de mémoire utilisée. Utilisez Édition → Préférences → Fenêtres d'image → Titre & état pour personnaliser l'information affichée dans cette barre d'état. Si l'opération en cours demande du temps, une barre de progression est affichée.

Note:


C'est la place occupée en mémoire par l'image affichée qui est indiquée ici, et non pas la taille de l'image. Une image .PNG de 69,7 Ko, par exemple, occupera 246 Ko en mémoire une fois affichée. Deux raisons à cela. D'abord, l'image est reconstituée à partir des données du fichier comprimé .PNG. Ensuite, GIMP garde en mémoire un double de l'image qui sera utilisé par la commande Rétablir.


10. Bouton Annuler :



pendant les opérations qui demandent du temps, un bouton d'annulation temporaire apparaît dans le coin en bas à droite de la fenêtre et vous permet d'interrompre l'opération si vous le désirez.

Note:


Il y a quelques greffons qui répondent mal à l'arrêt et peuvent altérer des parties de l'image.


11. Bouton Navigation :



C'est un petit bouton avec une croix dont les bras sont des flèches situé en bas à droite de la fenêtre image. Cliquer dessus et maintenir le bouton gauche de la souris enfoncé fait apparaître une fenêtre montrant une vue miniature de l'image (Aperçu de Navigation) et la partie actuellement affichée encadrée. Vous pouvez vous déplacer dans l'image en bougeant la souris tout en maintenant le bouton pressé. Pour les images de grande taille, dont une petite partie seulement est affichée, la fenêtre de navigation est souvent la manière la plus simple d'afficher la partie qui vous intéresse (voir dialogue de Navigation pour les autres manières d'accéder à la fenêtre de navigation). (Si votre souris possède une molette, le fait de cliquer avec dans l'image vous permet de vous déplacer dans l'image).

12. Partie inactive de la fenêtre image :



Ce remplissage sépare, dans la fenêtre image, la partie active de l'image de la partie inactive, ainsi vous pouvez faire la distinction entre elles. Vous ne pouvez pas appliquer de filtres ni, plus généralement, faire d'opération sur la partie inactive.

13. Affichage de l'image :



La partie la plus importante de la fenêtre image est, bien entendu, l'image elle-même. Elle occupe la partie centrale de la fenêtre, entourée d'un tireté jaune et noir montrant les limites de l'image, sur un fond gris neutre. Vous pouvez changer le niveau de zoom de la fenêtre image de diverses manières, y compris avec le paramètre du comportement du zoom décrit plus bas.

14. Redimensionner la fenêtre après un changement de taille :



Pas besoin d'explications...

Astuce:


Cliquer-glisser une image dans la Boîte à outils pour ouvrir l'image dans sa propre fenêtre. C'est tout à fait différent du fait de cliquer-glisser une image dans une autre image, qui ajoute la nouvelle image dans un nouveau calque.
Cette page a été vue 1869 fois